Firefox

If you use Firefox, an add-on is required to use the eID.

To install, go to the Firefox menu> Add-ons> Extension.

Two options:

  • Either you use the Belgium eID module developed by FEDICT already identified but must be activated,
  • or if it is not in the list and you can search for and add it. Once the installation is completed, restart Firefox before attempting to access the Brussels Health Network platform.

Warning for doctors – if Firefox is used to access your secure space and its various features, the patient registration application does not work with this browser.